-
TP- LINK ADSL2+ Modern Router (TD-8961N)
Key Features
Interface
4 10/100Mbps RJ45 Ports 1 RJ11 Port
Button
1 Power On/Off Switch 1 WPS Button 1 Wi-Fi On/Off Button
External Power Supply
9VDC/0.85A
IEEE Standards
IEEE 802.3, 802.3u
ADSL Standards
Full-rate ANSI T1.413 Issue 2, ITU-T G.992.1(G.DMT), ITU-T G.992.2(G.Lite) ITU-T G.994.1 (G.hs), ITU-T G.995.1
ADSL2 Standards
ITU-T G.992.3 (G.dmt.bis), ITU-T G.992.4 (G.lite.bis)
ADSL2+ Standards
ITU-T G.992.5
Dimensions ( W x D x H )
7.7 * 5.1 * 1.4 in. (195 * 130 * 35 mm )
Antenna Type
Omni directional, Fixed
Antenna Gain
2x5dBi
WIRELESS FEATURES
Wireless Standards
IEEE 802.11n, 802.11g, 802.11b
Frequency
2.400-2.4835GHz
Transmit Power
<20dBm(EIRP)
Wireless Security
Support 64/128 bit WEP, WPA-PSK/WPA2-PSK, Wireless MAC Filtering
SOFTWARE FEATURES
Quality of Service
QoS Remarking based on IPP/ToS, DSCP and 802.1p
Security
NAT Firewall, SPI Firewall, MAC / IP / Packet / Application / URL Filtering, Denial of Service(DoS), SYN Flooding, Ping of Death
Management
Web Based Configuration(HTTP), Remote management, Telnet management, Command Line Interface, SSL for TR-069, SNMP v1/2c, SNMP over EOC, Web Based Firmware Upgrade, CWMP(TR-069), Diagnostic Tools
Port Forwarding
Virtual Server, DMZ, ACL(Access Control List)
VPN Pass-Through
PPTP, L2TP, IPSec Pass-through
ATM/PPP Protocols
ATM Forum UNI3.1/4.0, PPP over ATM (RFC 2364), PPP over Ethernet (RFC2516), IPoA (RFC1577/2225), PVC - Up to 8 PVCs
Advanced Features
Traffic Shaping(ATM QoS) UBR, CBR, VBR-rt, VBR-nrt; Dynamic Host Configuration Protocol (DHCP), DHCP relay; Network Address Translation (NAT); PVC/Ethernet Port Mapping VLAN, 802.1P, Static Routing, RIP v1/v2 (optional); DNS Relay, DDNS, IGMP snooping V1/2 IGMP Multicast, UPnP
OTHERS
Certification
CE, FCC, RoHS
Package Contents
TD-W8961N
External Splitter
RJ-11 Telephone Cable
RJ-45 Ethernet Cable
Quick Installation Guide
Power Adapter
System Requirements
Microsoft® Windows® 98SE, NT, 2000, XP, Vista™ ,Windows 7 or Windows 8, MAC® OS, NetWare®, UNIX® or Linux.
Environment
Operating Temperature: 0℃~40℃ (32℉~104℉)
Storage Temperature: -40℃~70℃ (-40℉~158℉)
Operating Humidity: 10%~90% non-condensing
Storage Humidity: 5%~90% non-condensing
$29.99$30.00 -
HP 15 Nia Laptop Core™ i5 1235U 12th Generation
Key Features
-
Processor: 12th Gen Intel Core i5-1235U up to 4.4 GHz
-
RAM: 8GB DDR4
-
Storage: 256GB PCIe® NVMe™ M.2 SSD
-
Display: 15.6 inch FHD Antiglare Micro-Edge Display
-
Resolution: 1920 x 1080 pixels
-
Intel® Iris® X™ Graphics
-
OS: Windows 11 Home
$749.99$750.00 -
-
Canon 2540 Deskjet
Key Features
-
Category: Home and Office
-
All-In-One: (Copy, Scan, Fax )
-
Ink Technology: –Standard Ink Cartridges
-
Scanner Type: CIS flatbed photo and document scanner
-
Fax Type: Super G3/Color Communication
-
Printer Output – Color and Black
-
Connectivity -Hi-Speed USB (B Port)
-
Maximum Paper Size: Plain paper: A4, A5, B5, Letter, Legal Photo paper: 10x15cm, 13x18cm Envelopes: DL, COM10
$74.99$75.00 -
-
Canon MF3010
Key Features
-
Category: Home and Office
-
All-In-One: (Print, Copy, Scan)
-
Ink Technology: – 2 FINE Cartridges (BK, CL)
-
Scanner Type: Flatbed
-
Printer Output – Color
-
Connectivity -USB 2.0 Hi-speed
-
Maximum Paper Size: A4, B5, A5, Executive, Envelope (COM10, Monarch, DL, B5, C5), LTR, LGL, Statement, Custom sizes: Width 76 x 216 mm; Length 127 x 356 mm.
$229.99$230.00 -
-
Canon TR4540
Key Features
-
Category: Home and Office
-
All-In-One: (Wireless, Print, Copy, Scan, Fax & Cloud Link)
-
Ink Technology: – 2 FINE Cartridges (BK, CL)
-
Scanner Type: Flatbed & ADF
-
Fax Type: Super G3/Color Communication
-
Printer Output – Color (CMY)
-
Connectivity -USB, Wi-Fi, Wi-Fi Direct
-
Maximum Paper Size: A4
-
Supports Duplex: Yes
$129.99$130.00 -
-
Epson L3110
Key Features
-
Category: Home and Office
-
All-In-One: (Print, Copy, Scan)
-
Ink Technology: – Dye Ink
-
All-in-One Function: Print
-
Printer Output – Colour
-
Connectivity -USB, Wi-Fi, Wi-Fi Direct
-
Maximum Paper Size: A4
-
Supports Duplex: Yes
$269.99$270.00 -
-
Epson L3150
Key Features
- Category: Home and Office
- All-In-One: (Print, Copy, Scan)
- Ink Technology: – Dye Ink
- All-in-One Function: Print
- Printer Output – Colour
- Connectivity -USB, Wi-Fi, Wi-Fi Direct
- Maximum Paper Size: A4
- Supports Duplex: Yes
$324.99$325.00 -
Epson L1110
Key Features
-
All-in-One Printer: Ideal for Home and Office
-
Ink Technology: – Dye Ink
-
All-in-One Function: Print
-
Printer Output – Colour
-
Connectivity -USB
-
Maximum Paper Size: A4
-
Supports Duplex: Yes
$269.99$270.00 -
-
Epson L3116
Features
-
Ideal usage – Home and Small office -
Printer Type – Ink Tank -
Functionality – All-in-One (Print, Scan, Copy) -
Scanner type – Flatbed -
Printer Output – Colour -
Connectivity- USB -
Pages per minute – 33 pages (Black & White), 15 pages (Colour) -
Page size supported – A4, A5, A6, B5, C6, DL -
Duplex Print – Manual Print resolution – 5760 x 1440 -
Compatible Ink Bottle – T003 (Black), T003 (Cyan), T003 (Magenta), T003 (Yellow)
$339.99$340.00 -
-
HP Smart Tank 515
Key Features
-
A4 Color Inkjet All-in-One Printer, Perfect for Home
-
All-In-One: Print, Scan and Copy
-
Print speed: 11 ppm (black) and 5 ppm (color)
-
Connectivity: USB, Wi-Fi, Bluetooth
-
Colour compatibility: Yes Maximum paper size: A4
$289.99$290.00 -
-
Epson EcoTank L3211
Key Features
-
Epson EcoTank L3211 All-in-One Printer
-
Best ink tank printer under 10000
-
Printer Type – Ink Tank
-
All-in-One (Print, Scan, Copy)
-
Scanner type – Flatbed
-
Printer Output – Colour
-
Connectivity -USB, App
$289.99$290.00 -
-
HP 250 G7 Laptop (Celeron Dual Core)
Key Features
-
Processor: Intel Celeron Dual-Core Processor
-
Display: 15.6" (39.62 cm) display, 1366 x 768 px
-
RAM: 4 GB DDR4 RAM
-
Storage: 1 TB HDD
$349.99$350.00 -
-
Lenovo IdeaPad 3 15IGL05 FHD Celeron N4020
Key Features
-
Display: 15.6 inches, FHD
-
Memory: 4GB DDR4 RAM
-
Storage: 1TB SSD ROM
-
Processor: Intel Celeron
-
OS: DOS
-
Graphics: Intel UHD
$329.99$330.00 -
-
HP Laptop, Intel® Core™ i3 1215U 12th Generation
Features
-
Processor Brand: Intel® Core™ i3 1215U 12th Generation -
Memory size: 4 GB DDR4
-
Storage capacity: 256 GB SSD
-
Screen size: 15.6"
-
Battery life: Up to 7 hours and 45 minutes -
Operating system: FreeDOS
$549.99$550.00 -
-
HP Laptop, Intel® Core™ i7-1255U 12th Generation
Features
-
Processor: Intel® Core™ i7-1255U (up to 4.7 GHz with Intel® Turbo Boost Technology, 12 MB L3 cache, 10 cores, 12 threads) -
Memory size: 8 GB DDR4 3200 DIMM -
Storage capacity: 512 GB SSD
-
Operating system: FreeDOS
$949.99$950.00 -
-
Tecno Pova Neo
Features
-
Internal Memory: 64GB
-
RAM: 4GB
-
CPU: Octa-core (4x2.0 GHz Cortex-A53 & 4x1.5 GHz Cortex-A53)
-
Battery Capacity: Li-Po 6000 mAh, non-removable
-
Network: GSM / HSPA / 4G LTE
$129.99$130.00 -
-
Tecno Pop 7 Pro
Features
-
Internal Memory: 64GB
-
RAM: 7GB
-
CPU: Quad-core 2.0 GHz Cortex-A53
-
Battery Capacity: Li-Po 5000 mAh, non-removable
-
Network: GSM / HSPA / 4G LTE
$119.99$120.00 -
-
Tecno Spark 10
Features
-
Internal Memory: 128GB
-
RAM: 8GB
-
CPU: Octa-core (4x2.3 GHz Cortex-A53 & 4x1.7 GHz Cortex-A53)
-
Battery Capacity: Li-Po 5000 mAh, non-removable
-
Network: GSM / HSPA / 4G LTE
$139.99$140.00 -
Shop By Category
- Acer
- Bedroom
- Bedroom Suites
- Beds
- Bottom freezer
- Chest of freezers
- Coffee Tables
- Dinning Room
- Dish Washer
- Dressing Tables
- Electricals
- Electronics
- Furniture
- Hisense
- Kitchen
- Kitchen units
- Laptops
- Living Room
- Microwave
- Networking
- Phones
- Printers
- Refridgerators
- Routers
- Stoves
- Televisions
- Top freezers
- TV Stands
- Uncategorized
- Wardrobe
- Wardrobes
- Washing Machine
- Water dispensers
















