-
-
555lt Side by Side Fridge – Freezer
- A Energy Efficiency
- Satin Metallic Finish
- Dual Cooling Technology
- Superior Frost Free
- 555 Litre Net Volume
- LED Illumination
- Antibacterial Door Seal
- Door Open Alarm
- Dimensions (H x W x D)
- 1785 x 910 x 700 mm
- Fridge Section
- 369 Litre Net Volume
- Antibacterial Odour Filter
- Safety Glass Shelves
- Sealed Crispers
- Egg Tray
- Freezer Section
- 190 Litre Net Volume
- 4 Star Freezer
- Ice Cube Tray
-
-
-
KIC 570Ltr Chest Freezer
Features
-
543L Nett Capacity
-
Lockable
-
Metal Baskets
-
Vari-Freeze Control
-
Direct Cooling
-
‘A’ Energy Rating – Store more food with less consumption
-
Keep your food fully frozen (-18/-9°C) for up to 46 hours
-
Unpacked Dimensions: (HxWxD ) 875x1751x665mm
-
Download user manual
$649.99$650.00 -
-
-
-
Samsung Galaxy A14 128GB
Features
-
Ram: 6 GB RAM
-
Storage Capacity: 128 GB ROM
-
Display: 16.76 cm (6.6 inch) HD+ Display
-
Front Camera: 50MP + 2MP Back Camera: 13MP
-
Battery: 5000 mAh Lithium Ion
-
Processor: SEC S5E8535 (Exynos 1330)
$279.99$280.00 -
-
Itel A18
Features
-
Display: 5.0 inch 480 x 854 pixels WVGA display
-
Camera: 5 MP Back / 0.3MP front
-
Memory: 1GB RAM / 32GB ROM
-
Platform: UNiSOC SC9831E / Android 10
-
Camera Sensor(s): 5-megapixel main camera -
2G Network Bands: GSM 850 / 900 / 1800 -
Battery Capacity: Removable Li-Ion 2400 mAh
$54.99$55.00 -
-
Tecno Pop 7 Pro
Features
-
Internal Memory: 64GB
-
RAM: 7GB
-
CPU: Quad-core 2.0 GHz Cortex-A53
-
Battery Capacity: Li-Po 5000 mAh, non-removable
-
Network: GSM / HSPA / 4G LTE
$119.99$120.00 -
-
Epson L3116
Features
-
Ideal usage – Home and Small office -
Printer Type – Ink Tank -
Functionality – All-in-One (Print, Scan, Copy) -
Scanner type – Flatbed -
Printer Output – Colour -
Connectivity- USB -
Pages per minute – 33 pages (Black & White), 15 pages (Colour) -
Page size supported – A4, A5, A6, B5, C6, DL -
Duplex Print – Manual Print resolution – 5760 x 1440 -
Compatible Ink Bottle – T003 (Black), T003 (Cyan), T003 (Magenta), T003 (Yellow)
$339.99$340.00 -
-
TP- LINK ADSL2+ Modern Router (TD-8961N)
Key Features
Interface
4 10/100Mbps RJ45 Ports 1 RJ11 Port
Button
1 Power On/Off Switch 1 WPS Button 1 Wi-Fi On/Off Button
External Power Supply
9VDC/0.85A
IEEE Standards
IEEE 802.3, 802.3u
ADSL Standards
Full-rate ANSI T1.413 Issue 2, ITU-T G.992.1(G.DMT), ITU-T G.992.2(G.Lite) ITU-T G.994.1 (G.hs), ITU-T G.995.1
ADSL2 Standards
ITU-T G.992.3 (G.dmt.bis), ITU-T G.992.4 (G.lite.bis)
ADSL2+ Standards
ITU-T G.992.5
Dimensions ( W x D x H )
7.7 * 5.1 * 1.4 in. (195 * 130 * 35 mm )
Antenna Type
Omni directional, Fixed
Antenna Gain
2x5dBi
WIRELESS FEATURES
Wireless Standards
IEEE 802.11n, 802.11g, 802.11b
Frequency
2.400-2.4835GHz
Transmit Power
<20dBm(EIRP)
Wireless Security
Support 64/128 bit WEP, WPA-PSK/WPA2-PSK, Wireless MAC Filtering
SOFTWARE FEATURES
Quality of Service
QoS Remarking based on IPP/ToS, DSCP and 802.1p
Security
NAT Firewall, SPI Firewall, MAC / IP / Packet / Application / URL Filtering, Denial of Service(DoS), SYN Flooding, Ping of Death
Management
Web Based Configuration(HTTP), Remote management, Telnet management, Command Line Interface, SSL for TR-069, SNMP v1/2c, SNMP over EOC, Web Based Firmware Upgrade, CWMP(TR-069), Diagnostic Tools
Port Forwarding
Virtual Server, DMZ, ACL(Access Control List)
VPN Pass-Through
PPTP, L2TP, IPSec Pass-through
ATM/PPP Protocols
ATM Forum UNI3.1/4.0, PPP over ATM (RFC 2364), PPP over Ethernet (RFC2516), IPoA (RFC1577/2225), PVC - Up to 8 PVCs
Advanced Features
Traffic Shaping(ATM QoS) UBR, CBR, VBR-rt, VBR-nrt; Dynamic Host Configuration Protocol (DHCP), DHCP relay; Network Address Translation (NAT); PVC/Ethernet Port Mapping VLAN, 802.1P, Static Routing, RIP v1/v2 (optional); DNS Relay, DDNS, IGMP snooping V1/2 IGMP Multicast, UPnP
OTHERS
Certification
CE, FCC, RoHS
Package Contents
TD-W8961N
External Splitter
RJ-11 Telephone Cable
RJ-45 Ethernet Cable
Quick Installation Guide
Power Adapter
System Requirements
Microsoft® Windows® 98SE, NT, 2000, XP, Vista™ ,Windows 7 or Windows 8, MAC® OS, NetWare®, UNIX® or Linux.
Environment
Operating Temperature: 0℃~40℃ (32℉~104℉)
Storage Temperature: -40℃~70℃ (-40℉~158℉)
Operating Humidity: 10%~90% non-condensing
Storage Humidity: 5%~90% non-condensing
$29.99$30.00 -
LG 50-inch UHD TV
Key Features
Screen size50 InchesBrandLGSupported Internet servicesNetflix, Free Sat/Free View, Amazon Instant Video, YouTubeDisplay technologyLEDProduct dimensions9.8D x 44.1W x 27.7H centimetresResolution4KRefresh rate60 HzSpecial featureLEDModel name50UP81006LRIncluded componentsStand, Batteries x2, Screws, Magic Remote, User$569.99$570.00 -
Defy Double Door Metallic Fridge
Key Features
-
A Energy efficiency
-
Satin metallic finish
-
Dual Cooling Technology
-
Superior Frost Free
-
618 Litre net volume
-
LED illumination
-
Slimline water dispenser
-
Antibacterial door seal
-
Door open alarm
-
Dimensions (H x W x D) 1785 x 1000 x 700 mm
-
Fridge Section
-
369 Litre net volume
-
Antibacterial odour filter
-
Safety glass shelves
-
Sealed crispers
-
Egg tray
-
Freezer Section
-
249 Litre net volume
-
4 Star freezer
-
Ice cube tray
$1,349.99$1,350.00 -
-
Defy D200 Top Freezer (Metallic)
Key Features • A Energy efficiency • Static • Auto defrost • 151 Litre net volume • Interior light • Antibacterial door seal • Adjustable leveling feet • Variable thermostat • Dimensions (H x W x D) 1450 x 500 x 525 mm
$364.99$365.00
Shop By Category
- Acer
- Bedroom
- Bedroom Suites
- Beds
- Bottom freezer
- Chest of freezers
- Coffee Tables
- Dinning Room
- Dish Washer
- Dressing Tables
- Electricals
- Electronics
- Furniture
- Hisense
- Kitchen
- Kitchen units
- Laptops
- Living Room
- Microwave
- Networking
- Phones
- Printers
- Refridgerators
- Routers
- Stoves
- Televisions
- Top freezers
- TV Stands
- Uncategorized
- Wardrobe
- Wardrobes
- Washing Machine
- Water dispensers
















